
 

Avizo Basic User Guide 

Avizo is an image analysis software package designed to work smoothly with a variety of 3D 
imaging formats. Its particular strengths lie in its ability to perform a wide variety of analytical 
tasks on a particular data set, and in showing those analytical steps using a graphical 
workflow. 

The screenshots included here were taken from Avizo v. 9.7.0 and may be slightly different 
than what you see if the software has been updated, but should be similar enough to be easy 
to follow. 

The instructions below are designed to provide a general overview that will acquaint most 
users with the basics that they need to get started, based on BRC-Imaging staff’s experience 
with a lot of different data types and researcher requests. However, Avizo is a huge software 
package with a lot of depth to it and a somewhat steep learning curve. The methods outlined 
below are far from the only way to obtain useful data. If you have a method you prefer, feel 
free to share, and if you have questions, feel free to stop by the lab or contact us at 
brc_imaging_ct@cornell.edu. If you have a particular task not covered here but are new to 
Avizo, please refer to the application notes after reviewing this document. 

A note for first time users: The first time you load Avizo on either the B45 or B46 computer, 
you will need to enter the name of the server that the computer needs to ping to confirm a 
current license. Click the “Use FNP license server” button and enter our FNP license server 
address, which is keyserver2.biotech.cornell.edu. Click Activate. Avizo should now start up 
normally with the correct FNP license.  
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1) Download and unzip data folder. 
For users on the B46 computer, please put your data onto the H: (RAID) drive in the “All User 
Images Here” folder, and delete it from the “downloads” folder or desktop as the C: drive has 
limited space. (Your data will load and process more smoothly if it is local rather than 
networked or from an external hard drive.) Once you’ve finished your analysis, back up your 
project, either on the fileshare (Z: drive) or somewhere else of your choosing. The BRC will not 
archive data on lab computers. We will delete data that has been on lab computers for more 
than a month, though we will usually contact you if your folder is clearly labeled with your 
name.  

2)  Load dataset in Avizo. 
Start up the Avizo software. (If the License Manager window pops up, please refer to the 
instructions at the top of this manual for first time users.) Click the Open Data button or click 
FileOpen Data, and select all of the files that comprise your data set.  

A few notes on opening your data set: 

-The folder will need to be unzipped if it isn’t already.  

-Your downloaded folder might include non-data files (such as text files that 
include the scanning/reconstruction recipe, specimen information, or screenshots 
of the reconstructed data set). Don’t include these—the software is not smart 
enough to parse these and filter them out. 

-The selected files need to be part of a continuous set (i.e., starting from 
file_0001.dcm and going to file_1000.dcm, with no jumps.) The software is not 
smart enough to parse discontinuities, except to warn you that they exist. If there 
are missing files, try downloading and unzipping the data again, and/or discuss 
this with the staff member who performed the scan. Note that the data CAN start 
or end at any arbitrary number, everything in the middle just needs to be 
continuous. 

-A single .am file (Avizo’s data format) will contain all of the slices in it. If you’re 
working with a .am file you’ll only have one to open. 

Note: Projects will be discussed later, but if you have one you want to open, you’ll just need to 
open that one file to get the whole project loaded. 

For files larger than about 1GB, you will get an Out-of-Core Data warning: 
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For files up to about 30GB in size, you can read the complete volume into memory. The B46 
computer has plenty of processing power, so you don’t need to convert your data. 

For DICOMs, a window will pop up that shows all of the slices through the data. Click OK to 
continue. (If the slices are showing up as red instead of black, or if the files don't load correctly, 
contact BRC staff for assistance.) 

For file types that lack metadata about resolution, the Image Read Parameters window will pop 
up. Enter the resolution in x, y, and z, respectively in the voxel size boxes (units are mm).  

  
 

3) Visualize your data in 2D in the Project Tab 
When you load your data, you will move to the Project Tab, which will typically be set up as 
seen below. If it’s the first data set being loaded since the software was opened, you may 
already see a single 2D slice through the object in the visualization window. 



4 
 

 

 
Visualization Window: The large window is the visualization window, which shows 2D or 3D 
data. 

Project View: The project view window (upper left window) is a graphical representation of the 
workflow that had been done so far, and is where you can set up new calculations, 
visualizations, etc.  

Green objects represent data sets, and can be saved in a variety of formats. The images 
below show two different Project View windows; first, a simple Project View window similar to 
what you might see after loading data, and a more complex project view window that shows 
several mathematical functions (in red), savable data files(in green), and multiple 2D and 3D 
visualizations (in orange and yellow). 

    

To look at the data in 2D (assuming Avizo didn’t automatically create the Ortho slice function), 
Right click on the green data object in the Project View and select “Ortho Slice”. You should be 
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able to find Ortho Slice in the Favorites folder, the Display folder, or you can type it into the 
search box. 

 

Once selected, it will show up as an orange object in the Project View window, and should 
appear in the main visualization window. If you don’t want to see it in the visualization window, 
you can either remove the Ortho Slice object entirely by dragging it into the trash can in the 
Project View window or by clicking the small orange square: 

 

To make further adjustments to the 2D view—for example, to change the location of the 2D 
slice or brightness/contrast—click Ortho Slice and look at the Properties window in the lower 
left (if not visible, go to Window->Properties). 
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Properties window: When you click on an object in the Project View Window, the Properties 
Window will show information about and variables that can be changed on that object.  

For a green data object, for example, it will show the resolution and other information about the 
file, and is where you fill find options to crop your data set or change its location relative to 
other images that have been loaded. For a mathematical function which will be applied to the 
file, it will show the variables that can be applied to the data set before clicking Apply. In the 
Ortho Slice example we see below, it shows a variety of way of viewing the data in 2D. These 
include: 

 -Changing the plane being viewed (xy, xz, or yz) 

 -The slice number being shown 

-The colormap (brightness, contrast, and color combination), which can be adjusted by 
dragging the sliders on the histogram or choosing a color look up table from the drop-
down menu 

-The shading and transparency of the slice 

-Help with learning more about these options (the question mark in the corner: the help 
section can generally be very specific and helpful if your question is “what does this 
button do,” less so when your question is “how do I make it look like this other image I 
have?” Feel free to contact BRC staff for assistance with the latter.) 
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4) View the data in 3D. 
Right click on the green data object and select Volume Rendering from Favorites. Two Volume 
Rendering-related objects will appear in the Project View window, and a 3D rendering will 
appear in the Visualization window. In the view below, both the Ortho Slice and Volume 
Rendering are being shown simultaneously. Again, to toggle either view, click the small orange 
box inside the object. 

 

At the start, the whole scanned region, including air, may be visible. The brightness and 
contrast can be adjusted by clicking the Yellow Volume Rendering object, and adjusting the 
handles on the “Colormap” slider in the Properties window. When using any of Avizo’s 
volumetric colormaps, the transparency will be adjusted automatically as the brightness and 
contrast are adjusted.  

 

Menu bar keys: To manipulate the volume rendering, you’ll need to use some of the buttons 
along the top menu bar, which change the function of clicking and dragging the mouse button.  

 

There are some I rarely use, but I will highlight the most useful ones below. 

 

This section adjusts the data set, by rotating, shifting, and zooming the data. The “Set Home” 
button relocates the centerpoint around which the data rotates to the center of the screen. 
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This section enables you to do things like create a stereoscopic view of your data for use with 
3D glasses, take measurements, and take screenshots 

 

5) Segment your data set 
There are a variety of reasons you may want to segment your data. Here are a few commonly 
encountered by BRC users:  

-You want to remove or highlight a particular part of your scan for an improved final 
image. 

-You want to select one part of your scan to 3D print. 

-You want to analyze some part of your scan based on parameters you’ll choose later.  

Some objects are easier to segment out than others, and some researcher needs are more 
stringent than others, but the basic workflow is the same either way. 

To start segmenting, right click on the green data set object in the Project View tab and select 
“Edit New Label Field” from the Favorites folder or search bar. This will send you to the 
Segmentation tab. (Note: you can go back to the Project tab any time without losing your 
progress.) 

The basic principle of how Avizo does segmentation is as follows: First, it creates a new 
parallel dataset, of the same dimensions as the original dataset. You can only edit this dataset 
in the Segmentation tab. (If you go back to the Project tab, you will see a new green object 
attached to the original data, with the filename extension “filename.labels”.) Every voxel in a 
segmented image is assigned a value. To start with, they are all assigned a value of 0, 
corresponding to the gray label named “Exterior”.  

You can select any number of voxels using any combination of the tools in the lower left area. 
These will show up as a solid red color in both 2D and 3D view, but it’s important to note that 
selecting the data does not change the dataset unless you have told Avizo what to do with the 
selection. 

Once a region is selected, you can choose to add it to a label, subtract it from a label 
(subtracting it will reassign it to the “Exterior” label and give it a value of 0), or click the eraser 
button to undo the selections you’ve made. You can make any number of labels, and voxels in 
those labels will be assigned a value of 1, 2, 3, etc. Once the selected voxels are assigned to a 
label, you will see a shaded area overlaid the original grayscale data in the 2D views. 
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An overview of the Segmentation tab: 

 

 
As in the Project view, the large main window displays the data. Here, the upper left corner will 
show a 3D view, and the other three windows are the xy, yz, and xz slices through the data, 
respectively. The 3D view can be manipulated using tools along the top bar just as in the 
Project tab. 

The upper left area shows any labels you have created and their respective color codes. By 
default, Avizo gives you two, “Exterior” (value of 0) and “Interior” (value of 1). You can add 
labels, or change label names and colors by right clicking in this area. By default, the labels 
have a value of 0, 1, 2, 3, etc. You can also choose to display your selections in 2D or 3D 
using the toggle buttons on the right side of the image below. 

 

The middle-left section adjusts the brightness and contrast of the displayed data. 

 

 



10 
 

The middle left section, “Display Control”, allows you to adjust the brightness and contrast in 
the main window. 

 

 

 
The “Selection” section shows all of the things you can do once you select some portion of the 
data. Options include: 

-Clearing the selection (i.e., not adding or removing it from any existing label field)—
farthest left “eraser” button 

-Adding or removing it from a label field (to do this, click on the label you want to modify 
and then + or -) 

-Grow or shrink the selection, which takes the entire selection and shrinks or grows it by 
1 pixel in every dimension—farthest right buttons, showing squares with small arrows 
pushing in (shrink) or pushing out (grow) 

 

 

 
The bottom toolbar displays all the ways to select data. 

-Paintbrush and Lasso: Allow you to manually select an area of interest on a particular 
slice. To select a larger 3D region, you don’t need to manually select every single slice. 
Just pick slices with whatever spacing you like and then click SelectionInterpolate. 
Avizo will interpolate the initially-empty slices based on the information in the filled 
slices.  

-Magic Wand and Threshold: Segment based on brightness. The threshold tool will 
select every pixel within a particular brightness range. Use the handles on the bottom 
histogram to select the brightness range you want. The magic wand tool will select 
every pixel that is BOTH 1) Within the selected brightness range, and 2) directly or 
indirectly contacting the spot you click within that brightness range, via any bridging 
material within that brightness range. In the example below, the lower jaw has been 
selected using the magic wand tool, by clicking in that area and adjusting the brightness 
handles to select the region of interest. In the 2D view, everything that is gray is not 
within the chosen brightness range, and everything that is blue is within the brightness 
range, but is not linked to the pixel that was clicked via a path of similar brightness. Only 
the lower jaw, which is of a similar brightness and which does touch that selected voxel, 
is highlighted in red/purple. 
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Once the region of interest has been selected, you can add it to your desired material using 
the plus sign under the Selection bar. 

 

6) Viewing and manipulating segmented data 
Return to the Project tab at the top. You will see a new green object with the name 
[filename].labels just underneath the original data set. Right click on the new .labels data 
object and select Volume Rendering, to view the selection and the original grayscale data at 
the same time. For example, in the image below, you can see the original grayscale data 
showing a mouse, and the lower jaw has been selected and added to a label field. The section 
of the dataset that has been labeled can be analyzed by right-clicking and selecting the “Label 
Analysis” function. 
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